How to solve : WARNING: QA Issue: network-manager-applet rdepends on modemmanager, but it isn’t a build dependency? [build-deps]

Following are the errors which you may get while compiling bitbake and its solutions,

Error : 

WARNING: QA Issue: network-manager-applet rdepends on modemmanager, but it isn’t a build dependency? [build-deps]

Solution :

Open the network-manager-applet recipe and add RDEPENDS on modemmanager, as

RDEPENDS_${PN} =+ “modemmanager”

Note: This error we observed for network-manager-applet which we were working on, but you may see this error like “WARNING: QA Issue: XXXXXXX rdepends on YYYYYYY, but it isn’t a build dependency? [build-deps]” where X & Y may be any packages you are working on.. then also you will be able to fix this error using RDEPENDS …

Follow Lynxbee

Leave a Reply / Ask Question